Algoritmo para saber si un numero es mayor que otro

En matemáticas y programación, a menudo se necesita comparar dos números para determinar cuál es el mayor. Existen varios algoritmos para realizar esta tarea, cada uno con sus ventajas y desventajas. En este artículo, hablaremos sobre un algoritmo sencillo y eficiente para determinar si un número es mayor que otro.

Vamos aprender a realizar un algoritmo que determine cuál es el número mayor entre dos números ingresados por el usuario, el ejercicio lo vamos a comprobar en el programa pseint; además vamos a conocer el pseudocodigo para este algoritmo y su diagrama de flujo.

Problema:

Determinar cuál es el mayor de dos números enteros ingresados por el usuario y mostrar el mensaje en pantalla.

Como saber si un número es mayor que otro

Para determinar si un número es mayor que otro básicamente lo que debemos hacer es una comparación, es decir que debemos comparar el número 1 con el numero 2; ahora bien se puede dar el caso que los dos número sean iguales, por lo tanto será necesario también hacer la validación si los dos números son iguales.

Tutorial de Algoritmo para determinar el mayor de 2 números

En el siguiente tutorial te explico cómo realizar el algoritmo en pseint y generar su diagrama de flujo.

Pseudocodigo que compare dos números y determine cuál es mayor

El seudocódigo para determinar el número mayor entre dos números enteros, es el siguiente:

Algoritmo NumeroMayor

variables

   entero num1, num2

Inicio

   Escribir "Digite el primer número: "
   Leer num1

   Escribir "Digite el segundo número: "
   Leer num2

   Si num1 == num2 Entonces
      Escribir "Los dos números son iguales"

   SiNo
  Si num1 > num2 Entonces

        Escribir "El número mayor es: ",num1

    SiNo
        Escribir "El número mayor es: ",num2

  Fin Si

 Fin Si

Fin

Como determinar el número mayor en pseint

El algoritmo para saber si un número mayor que otro en pseint es el siguiente:

Algoritmo NumeroMayor

	Definir num1, num2 Como Entero

	Escribir "Digite el primer número: "
	Leer num1

	Escribir "Digite el segundo número: "
	Leer num2

	Si num1 == num2 Entonces
    
		Escribir "Los dos números son iguales"

	SiNo

		Si num1 > num2 Entonces

			Escribir "El número mayor es: ",num1			

		SiNo

			Escribir "El número mayor es: ",num2

		Fin Si

	Fin Si	

FinAlgoritmo

Explicación del algoritmo:

  1. Lo primero que hacemos es declarar dos variables de tipo entero llamadas num1 y num2, estas variables serán usadas para almacenar los números que ingrese el usuario.
  2. Luego con el comando escribir mostramos dos mensajes al usuario indicándole que digite los dos números; seguidamente de cada mensaje utilizamos el comando leer para capturar los datos que ingresara el usuario.
  3. Con el condicional si entonces, comparamos los dos números para saber si son iguales, en caso de cumplirse la condición enviaremos un mensaje que dirá: “Los dos números son iguales”.
  4. En caso de no cumplirse la condición, nuevamente hacemos una comparación y es para saber si el primer número es mayor que el segundo, en caso de cumplirse esa condición lo que hacemos es mostrar un mensaje indicando que el número mayor es el numero 1.
  5. No habiéndose cumplido las dos primeras condiciones el algoritmo pasaría a la opción «sino», en ese caso lo que ocurriría es que el número mayor es el segundo y por lo tanto lo mostraríamos en pantalla a través del comando escribir.
Mira también:  Algoritmo para calcular la edad de una persona

Diagrama de flujo para determinar el mayor de 2 números

El diagrama de flujo para determinar si un número es mayor que otro es el siguiente:

hacer un diagrama de flujo que permita leer 2 números diferentes y nos diga cual es el mayor de los 2 números.

Algoritmos, Pseudocodigo y diagramas de flujos

3 comentarios en «Algoritmo para saber si un numero es mayor que otro»

  1. Hola, buen día. Tengo que hacer un algoritmo que me indique cual es el nro menor, mayor y <> de los números tecleados, mi problema esta que condición usar para saber el numero en medio entre el mayor y el menor. ¿Me ayuda con ello?
    Gracias

    Responder
  2. Es decir: Dado una lista de n números leídos por teclado se desea conocer cual es el mayor de todos el menor de todos y otro número que este entre los dos. Ejemplo:
    1000,4,5,3,200,1
    En esta lista el mayor es 1000
    El menor es 1
    Y otro número que no.es mayor ni menor de todos seria el 3. Que condición debería usar para saber que ese 3?

    Responder
  3. 1. Realizar un programa donde me permita ingresar 4 notas de las siguientes materias, matematicas, compu, ingles, conta, y me permita elegir la materia para visualizar la nota

    Responder

Deja un comentario