Algoritmo para saber si un numero es par o impar

En programación, a menudo es necesario determinar si un número es par o impar para realizar ciertas operaciones o tomar decisiones en un programa. Existen diferentes algoritmos para realizar esta tarea, cada uno con sus ventajas y desventajas. En este artículo, te presentaremos un algoritmo sencillo y eficiente para determinar si un número es par o impar.

Aprenderás a crear un algoritmo que determine si un numero es par o impar, vamos a conocer el pseudocodigo, diagramara de flujo y programa en Pseint. Los datos serán leídos por teclado y mostrar el resultado en pantalla.

Problema:

Desarrolle un algoritmo que permita leer un valor cualquiera n y escriba si dicho número es par o impar.

Como saber si un número es par o impar

La respuesta es simple: cuando es divisible por 2 y el residuo es cero.

En programación se usa la función mod esta función también se representa en algunos lenguajes de programación con el símbolo %. La función MOD devuelve el residuo de la división que puede ser un uno o un cero.

Tutorial determinar numero par o impar en Pseint

En el siguiente tutorial te explico todo lo abordado en este articulo:

Pseudocodigo para saber si un numero es par o impar

Algoritmo ParImpar

variables
   entero numero

Inicio

   Escribir "Escriba un número: "
   Leer numero

   Si numero % 2 = 0 Entonces

      Escribir numero, " es par"

   SiNo

      Escribir numero, " no es par"

   Fin Si

Fin

Algoritmo en Pseint para saber si un numero es par o impar

Algoritmo ParImpar
 
    Escribir "Por favor ingrese un número"
    Leer num
 
    si num mod 2=0 Entonces
        Escribir num, " Es un número par"
    SiNo
        Escribir num, " No es un número par"
    FinSi
 
FinAlgoritmo

Explicación del algoritmo para determinar si un numero es par o impar

Mira también:  Algoritmo para determinar el mayor de 4 números

1: Lo primero que hacemos es declarar la variable, en este ejemplo utilizamos la variable num.
2: Con el comando escribir se envía un mensaje en pantalla solicitando que se ingrese un numero, recordemos que los mensajes se deben colocar entre comillas dobles «».
3: Con el comando leer asignamos el numero ingresado por teclado en la variable num.
4: Iniciamos la estructura de control si entonces y comparamos si el numero ingresado por teclado mod dos es igual a cero, es decir que si el residuo de la división es igual a cero, entonces esto quiere decir que el numero es par y lo que hacemos es enviar un mensaje en pantalla con la sentencia escribir indicando que el numero ingresado es par.
5: Cuando la condición no se cumpla, es decir que el residuo no sea cero entonces enviamos un mensaje en pantalla indicando que el numero es impar.
6: Finaliza la estructura condicional si entonces y finaliza el algoritmo.

Diagrama de flujo para saber si un numero es par o impar

El Diagrama de flujo para determinar si un numero es par o impar es el siguiente:

Diagrama de flujo saber si un numero es mayor

Algoritmos, Pseudocodigo y diagramas de flujos

2 comentarios en «Algoritmo para saber si un numero es par o impar»

  1. ¡Hola! Recién estoy empezando a programar…estoy haciendo un ejercicio en el que se me presenta un pseudocódigo para saber si un numero es par o impar y tengo que elegir entre ''2 programas simplificados''. La principal diferencia es que unos indica que se tiene que dividir entre dos primero y el otro ingresar directamente el número y te dice que es par o impar… Entiendo que siempre es necesario realizar la división para poder determinarlo,¿no?
    ¡Muchas gracias!

    Responder

Deja un comentario