Algoritmo para determinar si un numero es Positivo o Negativo

El uso de algoritmos es fundamental en la programación y resolución de problemas matemáticos. Uno de los problemas más básicos que se pueden abordar mediante algoritmos es la determinación de si un número es positivo o negativo. En este artículo, se presentará un algoritmo eficiente para esta tarea.

Algoritmo para saber si un numero es positivo o negativo

Vamos aprender a crear un algoritmo para determinar si un numero es positivo, negativo o neutro en pseint; además vamos a conocer el seudocódigo para este algoritmo y su diagrama de flujo.

Problema:

Realizar un algoritmo que determine si un numero ingresado por el usuario es positivo, negativo o neutro (cero), mostrar el mensaje en pantalla. Dicho de otra manera: desarrolle un algoritmo que permita leer un valor entero positivo n y determinar si es primo o no.

Como saber si un numero es positivo, negativo o cero 

Para determinar si un numero es positivo, negativo o cero, lo que debemos hacer es comparar y tendremos los siguientes escenarios:

  1. Si el numero es mayor a cero entonces es positivo.
  2. Si el numero es menor a cero entonces es negativo.
  3. En caso de no cumplirse ninguna de las dos condiciones anteriores, entonces se determina que el numero es cero.
Mira también:  Algoritmo para determinar el mayor de 4 números

Tutorial de Algoritmo Numero Positivo, Negativo o Cero en Pseint

En el siguiente tutorial les explico como crear el algoritmo y generar su diagrama de flujo:

Pseudocódigo para determinar si un numero es positivo o negativo

El Pseudocódigo para saber si un numero es positivo, negativo o cero es el siguiente:

Algoritmo PositivoNegativo

variables
   entero num

Inicio

   Escribir "Escriba un número: "
   Leer num

   Si num > 0 Entonces
      Escribir "El numero: ",num, " es Positivo"

   SiNo
  Si num<0 Entonces
   Escribir "El numero: ",num, " es Negativo"

    SiNo
   Escribir "El numero: ",num, " es Neutro"

  Fin Si
 Fin Si

Fin

Determinar si un numero es positivo o negativo en Pseint

El algoritmo para saber si un numero es positivo, negativo o cero en pseint es el siguiente:

Algoritmo PositivoNegativo
 
 Definir num Como Entero
 
 Escribir "Digita un numero: "
 leer num
 
 Si num>0 Entonces
  Escribir "El numero: ",num, " Es positivo"
 SiNo
  Si num<0 Entonces
   Escribir "El numero: ",num, " Es Negativo"
  SiNo
   Escribir "El numero: ",num, " Es Neutro"
  Fin Si
 Fin Si
  
FinAlgoritmo

Explicación del algoritmo:

  1. Lo primero que hacemos es declarar una variable de tipo entero llamada «num», esta se utilizara para guardar el numero ingresado por el usuario.
  2. A través del comando leer damos la opción al usuario para que ingrese un numero y el numero ingresado lo guardamos en la variable «num».
  3. Comparamos si el numero ingresado es mayor a cero, en caso de ser así enviamos el mensaje indicando que el numero es positivo.
  4. Comparamos si el numero ingresado es menor a cero, si es así enviamos el mensaje indicando que el numero es negativo.
  5. En la opción sino, enviamos el mensaje que el numero es neutro (nulo), ya que por defecto se sabe que al no ser positivo ni negativo entonces es cero.
Mira también:  Algoritmo que imprima 10 veces la palabra hola

Diagrama de flujo para saber si un numero es positivo o negativo

El diagrama de flujo para determinar si un numero es positivo o negativo es el siguiente:

diagrama de flujo si un numero es positivo o negativo

Algoritmos, Pseudocodigo y diagramas de flujos

9 comentarios en «Algoritmo para determinar si un numero es Positivo o Negativo»

  1. Excelente explicación, no se nada de programación y me pareció muy fácil e interesante,así como la manera de explicar en el video..es un gran profesor, no sólo por lo que sabe, sino también por la manera de enseñar sin egoísmos. Felicitaciones

    Responder
  2. Realizar un algoritmo que describa un menú de opciones con las siguientes opciones:
    1.Volumen cilindro
    (Determinara el porcentaje de llenado dado el ingreso de líquido en centímetros
    Cúbicos (cc) en un embace cilíndrico tomando en cuenta que su capacidad máxima de 600 y que tiene un radio de 10cm) usar regla de 3.
    2.Suma de números
    (Es algoritmo que suma los números pares e impares del ingreso de un numero inicial y otro final de una secuencia, para que al final muestre la suma de pares y de los impares
    3.Salir

    Responder
  3. pseudocodigo y diagrama de flujo que dice se desea implementar un algoritmo para determinar si un número es positivo ó negativo.

    Responder
  4. Problema 4.
    En un almacén se realiza una promoción de 3 tipos de productos:
    A que tiene un precio de $15.000
    B que tiene un precio de $20.000
    C que tiene un precio de $30.000
    El usuario debe elegir un producto e indicar la cantidad a comprar. El
    resultado debe ser el producto elegido y el valor a pagar.
    El programa termina cuando el usuario digita S o s

    Responder
  5. Construya un algoritmo que permita leer un cantidad variable de números e indicar finalmente de
    estos:
    • el promedio de todos los números pares leídos
    • el promedio de todos los números impares leídos
    • el número impar leído más grande
    • el número par leído más pequeño.

    Se deberá ir consultando al usuario si desea leer otro número cada vez.

    Responder

Deja un comentario